# CVE-2023-33246: Apache RocketMQ Command Execution Vulnerability - Exploited (CISA KEV): yes, added 2023-09-06 - Published: 2023-05-24 - CVSS: 9.8 CRITICAL (v3.1) - EPSS: 96.6% (100th percentile) - CWE: CWE-94 For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution.  Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content.  To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x . ## Edge WAF coverage (claimed by vendors, not measured) | Vendor | Status | First rule | Days after publication | |---|---|---|---| | Cloudflare | Before feed history | — | — | | AWS | No public claim | — | — | | Microsoft Azure | No public claim | — | — | | Google Cloud | Before feed history | — | — | | Fastly | Before feed history | — | — | | F5 | No public claim | — | — | | Akamai | No public source | — | — | | OWASP CRS | No public claim | — | — | "No public claim" means no vendor statement names this CVE; "Before feed history" means the CVE is older than the vendor feed. In both cases generic rules may still block it. HTML: https://cve.vigilbase.com/cve/CVE-2023-33246 · JSON: https://cve.vigilbase.com/api/v1/cves/CVE-2023-33246